Вставка диаграмм

Вставка диаграммы

Для вставки диаграммы в документ:

  1. установите курсор там, где требуется поместить диаграмму,
  2. перейдите на вкладку Вставка верхней панели инструментов,
  3. щелкните по значку Значок Диаграмма Диаграмма на верхней панели инструментов,
  4. выберите из доступных типов диаграммы тот, который вам нужен - гистограмма, график, круговая, линейчатая, с областями, точечная, биржевая,

    Обратите внимание: для Гистограмм, Графиков, Круговых или Линейчатых диаграмм также доступен формат 3D.

  5. после этого появится окно Редактор диаграмм, в котором можно ввести в ячейки необходимые данные при помощи следующих элементов управления:
    • Копировать и Вставить для копирования и вставки скопированных данных
    • Отменить и Повторить для отмены и повтора действий
    • Вставить функцию для вставки функции
    • Уменьшить разрядность и Увеличить разрядность для уменьшения и увеличения числа десятичных знаков
    • Формат чисел для изменения числового формата, то есть того, каким образом выглядят введенные числа в ячейках

    Окно Редактор диаграмм

  6. измените параметры диаграммы, нажав на кнопку Изменить диаграмму в окне Редактор диаграмм. Откроется окно Диаграмма - дополнительные параметры.

    Окно Диаграмма - дополнительные параметры

    На вкладке Тип и данные можно изменить тип диаграммы, а также данные, которые вы хотите использовать для создания диаграммы.
    • Выберите Тип диаграммы, который требуется применить: гистограмма, график, круговая, линейчатая, с областями, точечная, биржевая.
    • Проверьте выбранный Диапазон данных и при необходимости измените его, нажав на кнопку Выбор данных и указав желаемый диапазон данных в следующем формате: Лист1!A1:B4.
    • Измените способ расположения данных. Можно выбрать ряды данных для использования по оси X: в строках или в столбцах.

    Окно Диаграмма - дополнительные параметры

    На вкладке Макет можно изменить расположение элементов диаграммы:

    • Укажите местоположение Заголовка диаграммы относительно диаграммы, выбрав нужную опцию из выпадающего списка:
      • Нет, чтобы заголовок диаграммы не отображался,
      • Наложение, чтобы наложить заголовок на область построения диаграммы и выровнять его по центру,
      • Без наложения, чтобы показать заголовок над областью построения диаграммы.
    • Укажите местоположение Условных обозначений относительно диаграммы, выбрав нужную опцию из выпадающего списка:
      • Нет, чтобы условные обозначения не отображались,
      • Снизу, чтобы показать условные обозначения и расположить их в ряд под областью построения диаграммы,
      • Сверху, чтобы показать условные обозначения и расположить их в ряд над областью построения диаграммы,
      • Справа, чтобы показать условные обозначения и расположить их справа от области построения диаграммы,
      • Слева, чтобы показать условные обозначения и расположить их слева от области построения диаграммы,
      • Наложение слева, чтобы наложить условные обозначения на область построения диаграммы и выровнять их по центру слева,
      • Наложение справа, чтобы наложить условные обозначения на область построения диаграммы и выровнять их по центру справа.
    • Определите параметры Подписей данных (то есть текстовых подписей, показывающих точные значения элементов данных):
      • укажите местоположение Подписей данных относительно элементов данных, выбрав нужную опцию из выпадающего списка. Доступные варианты зависят от выбранного типа диаграммы.
        • Для Гистограмм и Линейчатых диаграмм можно выбрать следующие варианты: Нет, По центру, Внутри снизу, Внутри сверху, Снаружи сверху.
        • Для Графиков и Точечных или Биржевых диаграмм можно выбрать следующие варианты: Нет, По центру, Слева, Справа, Сверху, Снизу.
        • Для Круговых диаграмм можно выбрать следующие варианты: Нет, По центру, По ширине, Внутри сверху, Снаружи сверху.
        • Для диаграмм С областями, а также для Гистограмм, Графиков и Линейчатых диаграмм в формате 3D можно выбрать следующие варианты: Нет, По центру.
      • выберите данные, которые вы хотите включить в ваши подписи, поставив соответствующие флажки: Имя ряда, Название категории, Значение,
      • введите символ (запятая, точка с запятой и т.д.), который вы хотите использовать для разделения нескольких подписей, в поле Разделитель подписей данных.
    • Линии - используется для выбора типа линий для линейчатых/точечных диаграмм. Можно выбрать одну из следующих опций: Прямые для использования прямых линий между элементами данных, Сглаженные для использования сглаженных кривых линий между элементами данных или Нет для того, чтобы линии не отображались.
    • Маркеры - используется для указания того, нужно показывать маркеры (если флажок поставлен) или нет (если флажок снят) на линейчатых/точечных диаграммах.

      Примечание: Опции Линии и Маркеры доступны только для Линейчатых диаграмм и Точечных диаграмм.

    • В разделе Параметры оси можно указать, надо ли отображать Горизонтальную/Вертикальную ось, выбрав из выпадающего списка опцию Показать или Скрыть. Можно также задать параметры Названий горизонтальной/вертикальной оси:
      • Укажите, надо ли отображать Название горизонтальной оси, выбрав нужную опцию из выпадающего списка:
        • Нет, чтобы название горизонтальной оси не отображалось,
        • Без наложения, чтобы показать название под горизонтальной осью.
      • Укажите ориентацию Названия вертикальной оси, выбрав нужную опцию из выпадающего списка:
        • Нет, чтобы название вертикальной оси не отображалось,
        • Повернутое, чтобы показать название снизу вверх слева от вертикальной оси,
        • По горизонтали, чтобы показать название по горизонтали слева от вертикальной оси.
    • В разделе Линии сетки можно указать, какие из Горизонтальных/вертикальных линий сетки надо отображать, выбрав нужную опцию из выпадающего списка: Основные, Дополнительные или Основные и дополнительные. Можно вообще скрыть линии сетки, выбрав из списка опцию Нет.

      Примечание: разделы Параметры оси и Линии сетки будут недоступны для круговых диаграмм, так как у круговых диаграмм нет осей и линий сетки.

    Окно Диаграмма - дополнительные параметры

    Примечание: Вкладки Вертикальная/горизонтальная ось недоступны для круговых диаграмм, так как у круговых диаграмм нет осей.

    На вкладке Вертикальная ось можно изменить параметры вертикальной оси, которую называют также осью значений или осью Y, где указываются числовые значения. Обратите, пожалуйста, внимание, что для гистограмм вертикальная ось является осью категорий, на которой показываются текстовые подписи, так что в этом случае опции вкладки Вертикальная ось будут соответствовать опциям, о которых пойдет речь в следующей вкладке. Для точечных диаграмм обе оси являются осями категорий.

    • Раздел Параметры оси позволяет установить следующие параметры:
      • Минимум - используется для указания наименьшего значения, которое отображается в начале вертикальной оси. По умолчанию выбрана опция Авто; в этом случае минимальное значение высчитывается автоматически в зависимости от выбранного диапазона данных. Можно выбрать из выпадающего списка опцию Фиксированный и указать в поле справа другое значение.
      • Максимум - используется для указания наибольшего значения, которое отображается в конце вертикальной оси. По умолчанию выбрана опция Авто; в этом случае максимальное значение высчитывается автоматически в зависимости от выбранного диапазона данных. Можно выбрать из выпадающего списка опцию Фиксированный и указать в поле справа другое значение.
      • Пересечение с осью - используется для указания точки на вертикальной оси, в которой она должна пересекаться с горизонтальной осью. По умолчанию выбрана опция Авто; в этом случае точка пересечения осей определяется автоматически в зависимости от выбранного диапазона данных. Можно выбрать из выпадающего списка опцию Значение и указать в поле справа другое значение или установить точку пересечения осей на Минимум/Максимум на вертикальной оси.
      • Единицы отображения - используется для определения порядка числовых значений на вертикальной оси. Эта опция может пригодиться, если вы работаете с большими числами и хотите, чтобы отображение цифр на оси было более компактным и удобочитаемым (например, можно сделать так, чтобы 50 000 показывалось как 50, воспользовавшись опцией Тысячи). Выберите желаемые единицы отображения из выпадающего списка: Сотни, Тысячи, 10 000, 100 000, Миллионы, 10 000 000, 100 000 000, Миллиарды, Триллионы или выберите опцию Нет, чтобы вернуться к единицам отображения по умолчанию.
      • Значения в обратном порядке - используется для отображения значений в обратном порядке. Когда этот флажок снят, наименьшее значение находится внизу, а наибольшее - наверху. Когда этот флажок отмечен, значения располагаются сверху вниз.
    • Раздел Параметры делений позволяет определить местоположение делений на вертикальной оси. Деления основного типа - это более крупные деления шкалы, у которых могут быть подписи, отображающие цифровые значения. Деления дополнительного типа - это вспомогательные деления шкалы, которые располагаются между делениями основного типа и у которых нет подписей. Кроме того, деления шкалы указывают, где могут отображаться линии сетки, если на вкладке Макет выбрана соответствующая опция. В выпадающих списках Основной/Дополнительный тип содержатся следующие опции размещения:
      • Нет, чтобы деления основного/дополнительного типа не отображались,
      • На пересечении, чтобы показывать деления основного/дополнительного типа по обеим сторонам оси,
      • Внутри, чтобы показывать деления основного/дополнительного типа с внутренней стороны оси,
      • Снаружи, чтобы показывать деления основного/дополнительного типа с наружной стороны оси.
    • Раздел Параметры подписи позволяет определить положение подписей основных делений, отображающих значения. Для того, чтобы задать Положение подписи относительно вертикальной оси, выберите нужную опцию из выпадающего списка:
      • Нет, чтобы подписи не отображались,
      • Ниже, чтобы показывать подписи слева от области диаграммы,
      • Выше, чтобы показывать подписи справа от области диаграммы,
      • Рядом с осью, чтобы показывать подписи рядом с осью.

    Окно Диаграмма - дополнительные параметры

    На вкладке Горизонтальная ось можно изменить параметры горизонтальной оси, которую также называют осью категорий или осью X, где отображаются текстовые подписи. Обратите внимание, что для Гистограмм горизонтальная ось является осью значений, на которой отображаются числовые значения, так что в этом случае опции вкладки Горизонтальная ось будут соответствовать опциям, описанным в предыдущем разделе. Для точечных диаграмм обе оси являются осями значений.

    • Раздел Параметры оси позволяет установить следующие параметры:
      • Пересечение с осью - используется для указания точки на горизонтальной оси, в которой она должна пересекаться с вертикальной осью. По умолчанию выбрана опция Авто; в этом случае точка пересечения осей определяется автоматически в зависимости от выбранного диапазона данных. Можно выбрать из выпадающего списка опцию Значение и указать в поле справа другое значение или установить точку пересечения осей на Минимум/Максимум (что соответствует первой и последней категории) на горизонтальной оси.
      • Положение оси - используется для указания того, куда нужно выводить текстовые подписи на ось: на Деления или Между делениями.
      • Значения в обратном порядке - используется для отображения категорий в обратном порядке. Когда этот флажок снят, категории располагаются слева направо. Когда этот флажок отмечен, категории располагаются справа налево.
    • Раздел Параметры делений позволяет определять местоположение делений на горизонтальной шкале. Деления основного типа - это более крупные деления шкалы, у которых могут быть подписи, отображающие значения категорий. Деления дополнительного типа - это более мелкие деления шкалы, которые располагаются между делениями основного типа и у которых нет подписей. Кроме того, деления шкалы указывают, где могут отображаться линии сетки, если на вкладке Макет выбрана соответствующая опция. Можно регулировать следующие параметры делений:
      • Основной/Дополнительный тип - используется для указания следующих вариантов размещения: Нет, чтобы деления основного/дополнительного типа не отображались, На пересечении, чтобы отображать деления основного/дополнительного типа по обеим сторонам оси, Внутри, чтобы отображать деления основного/дополнительного типа с внутренней стороны оси, Снаружи, чтобы отображать деления основного/дополнительного типа с наружной стороны оси.
      • Интервал между делениями - используется для указания того, сколько категорий нужно показывать между двумя соседними делениями.
    • Раздел Параметры подписи позволяет установить местоположение подписей, которые отражают категории.
      • Положение подписи - используется для указания того, где следует располагать подписи относительно горизонтальной оси. Выберите нужную опцию из выпадающего списка: Нет, чтобы подписи категорий не отображались, Ниже, чтобы подписи категорий располагались снизу области диаграммы, Выше, чтобы подписи категорий располагались наверху области диаграммы, Рядом с осью, чтобы подписи категорий отображались рядом с осью.
      • Расстояние до подписи - используется для указания того, насколько близко подписи должны располагаться от осей. Можно указать нужное значение в поле ввода. Чем это значение больше, тем дальше расположены подписи от осей.
      • Интервал между подписями - используется для указания того, как часто нужно показывать подписи. По умолчанию выбрана опция Авто; в этом случае подписи отображаются для каждой категории. Можно выбрать опцию Вручную и указать нужное значение в поле справа. Например, введите 2, чтобы отображать подписи у каждой второй категории, и т.д.

    Диаграмма - дополнительные параметры

    Вкладка Альтернативный текст позволяет задать Заголовок и Описание, которые будут зачитываться для людей с нарушениями зрения или когнитивными нарушениями, чтобы помочь им лучше понять, какую информацию содержит диаграмма.


Перемещение и изменение размера диаграмм

Перемещение диаграммы После того, как диаграмма будет добавлена, можно изменить ее размер и положение. Для изменения размера диаграммы перетаскивайте маленькие квадраты Значок Квадрат , расположенные по ее краям. Чтобы сохранить исходные пропорции выбранной диаграммы при изменении размера, удерживайте клавишу Shift и перетаскивайте один из угловых значков.

Для изменения местоположения диаграммы используйте значок Стрелка, который появляется после наведения курсора мыши на диаграмму. Перетащите диаграмму на нужное место, не отпуская кнопку мыши. При перемещении диаграммы на экране появляются направляющие, которые помогают точно расположить объект на странице (если выбран стиль обтекания, отличный от стиля "В тексте").

Примечание: список сочетаний клавиш, которые можно использовать при работе с объектами, доступен здесь.


Редактирование элементов диаграммы

Чтобы изменить Заголовок диаграммы, выделите мышью стандартный текст и введите вместо него свой собственный.

Чтобы изменить форматирование шрифта внутри текстовых элементов, таких как заголовок диаграммы, названия осей, элементы условных обозначений, подписи данных и так далее, выделите нужный текстовый элемент, щелкнув по нему левой кнопкой мыши. Затем используйте значки на вкладке Главная верхней панели инструментов, чтобы изменить тип, размер, цвет шрифта или его стиль оформления.

Чтобы удалить элемент диаграммы, выделите его, щелкнув левой кнопкой мыши, и нажмите клавишу Delete на клавиатуре.

Можно также поворачивать 3D-диаграммы с помощью мыши. Щелкните левой кнопкой мыши внутри области построения диаграммы и удерживайте кнопку мыши. Не отпуская кнопку мыши, перетащите курсор, чтобы изменить ориентацию 3D-диаграммы.

3D-диаграмма


Изменение параметров диаграммы

Вкладка Параметры диаграммы

Некоторые параметры диаграммы можно изменить с помощью вкладки Параметры диаграммы на правой боковой панели. Чтобы ее активировать, щелкните по диаграмме и выберите значок Параметры диаграммы Значок Параметры диаграммы справа. Здесь можно изменить следующие свойства:

  • Размер - используется, чтобы просмотреть текущую Ширину и Высоту диаграммы.
  • Стиль обтекания - используется, чтобы выбрать один из доступных стилей обтекания текстом - в тексте, вокруг рамки, по контуру, сквозное, сверху и снизу, перед текстом, за текстом (для получения дополнительной информации смотрите описание дополнительных параметров ниже).
  • Изменить тип диаграммы - используется, чтобы изменить выбранный тип и/или стиль диаграммы.

    Для выбора нужного Стиля диаграммы используйте второе выпадающее меню в разделе Изменить тип диаграммы.

  • Изменить данные - используется для вызова окна 'Редактор диаграмм'.

    Примечание: для быстрого вызова окна 'Редактор диаграмм' можно также дважды щелкнуть мышкой по диаграмме в документе.

Некоторые из этих опций можно также найти в контекстном меню. Меню содержит следующие пункты:

  • Вырезать, копировать, вставить - стандартные опции, которые используются для вырезания или копирования выделенного текста/объекта и вставки ранее вырезанного/скопированного фрагмента текста или объекта в то место, где находится курсор.
  • Порядок - используется, чтобы вынести выбранную диаграмму на передний план, переместить на задний план, перенести вперед или назад, а также сгруппировать или разгруппировать диаграммы для выполнения операций над несколькими из них сразу. Подробнее о расположении объектов в определенном порядке рассказывается на этой странице.
  • Выравнивание - используется, чтобы выровнять диаграмму по левому краю, по центру, по правому краю, по верхнему краю, по середине, по нижнему краю. Подробнее о выравнивании объектов рассказывается на этой странице.
  • Стиль обтекания - используется, чтобы выбрать один из доступных стилей обтекания текстом - в тексте, вокруг рамки, по контуру, сквозное, сверху и снизу, перед текстом, за текстом. Опция Изменить границу обтекания для диаграмм недоступна.
  • Изменить данные - используется для вызова окна 'Редактор диаграмм'.
  • Дополнительные параметры диаграммы - используется для вызова окна 'Диаграмма - дополнительные параметры'.

При выборе диаграммы справа также появляется значок Параметры фигуры Значок Параметры фигуры, поскольку фигура используется в качестве фона для диаграммы. Щелкнув по этому значку, можно открыть вкладку Параметры фигуры на правой боковой панели инструментов и задать заливку, обводку и Стиль обтекания. Обратите внимание на то, что тип фигуры изменить нельзя.


Чтобы изменить дополнительные параметры диаграммы, щелкните по ней правой кнопкой мыши и выберите из контекстного меню пункт Дополнительные параметры диаграммы. Или нажмите ссылку Дополнительные параметры на правой боковой панели. Откроется окно свойств диаграммы:

Диаграмма - дополнительные параметры: Размер

Вкладка Размер содержит следующие параметры:

  • Ширина и Высота - используйте эти опции, чтобы изменить ширину и/или высоту диаграммы. Если нажата кнопка Сохранять пропорции Кнопка Сохранять пропорции (в этом случае она выглядит так: Кнопка Сохранять пропорции нажата), ширина и высота будут изменены пропорционально, сохраняя исходное соотношение сторон диаграммы.

Диаграмма - дополнительные параметры: Обтекание текстом

Вкладка Обтекание текстом содержит следующие параметры:

  • Стиль обтекания - используйте эту опцию, чтобы изменить способ размещения диаграммы относительно текста: или она будет являться частью текста (если выбран стиль обтекания "В тексте") или текст будет обтекать ее со всех сторон (если выбран один из остальных стилей).
    • Стиль обтекания - В тексте В тексте - диаграмма считается частью текста, как отдельный символ, поэтому при перемещении текста диаграмма тоже перемещается. В этом случае параметры расположения недоступны.

      Если выбран один из следующих стилей, диаграмму можно перемещать независимо от текста и и точно задавать положение диаграммы на странице:

    • Стиль обтекания - Вокруг рамки Вокруг рамки - текст обтекает прямоугольную рамку, которая окружает диаграмму.

    • Стиль обтекания - По контуру По контуру - текст обтекает реальные контуры диаграммы.

    • Стиль обтекания - Сквозное Сквозное - текст обтекает вокруг контуров диаграммы и заполняет незамкнутое свободное место внутри диаграммы.

    • Стиль обтекания - Сверху и снизу Сверху и снизу - текст находится только выше и ниже диаграммы.

    • Стиль обтекания - Перед текстом Перед текстом - диаграмма перекрывает текст.

    • Стиль обтекания - За текстом За текстом - текст перекрывает диаграмму.

При выборе стиля обтекания вокруг рамки, по контуру, сквозное или сверху и снизу можно задать дополнительные параметры - расстояние до текста со всех сторон (сверху, снизу, слева, справа).

Диаграмма - дополнительные параметры: Положение

Вкладка Положение доступна только в том случае, если выбран стиль обтекания, отличный от стиля "В тексте". Вкладка содержит следующие параметры, которые различаются в зависимости от выбранного стиля обтекания:

  • В разделе По горизонтали можно выбрать один из следующих трех способов позиционирования диаграммы:
    • Выравнивание (по левому краю, по центру, по правому краю) относительно символа, столбца, левого поля, поля, страницы или правого поля,
    • Абсолютное Положение, определяемое в абсолютных единицах, то есть Сантиметрах/Пунктах/Дюймах (в зависимости от того, какой параметр указан на вкладке Файл -> Дополнительные параметры...), справа от символа, столбца, левого поля, поля, страницы или правого поля,
    • Относительное положение, определяемое в процентах, относительно левого поля, поля, страницы или правого поля.
  • В разделе По вертикали можно выбрать один из следующих трех способов позиционирования диаграммы:
    • Выравнивание (по верхнему краю, по центру, по нижнему краю) относительно строки, поля, нижнего поля, абзаца, страницы или верхнего поля,
    • Абсолютное Положение, определяемое в абсолютных единицах, то есть Сантиметрах/Пунктах/Дюймах (в зависимости от того, какой параметр указан на вкладке Файл -> Дополнительные параметры...), ниже строки, поля, нижнего поля, абзаца, страницы или верхнего поля,
    • Относительное положение, определяемое в процентах, относительно поля, нижнего поля, страницы или верхнего поля.
  • Опция Перемещать с текстом определяет, будет ли диаграмма перемещаться вместе с текстом, к которому она привязана.
  • Опция Разрешить перекрытие определяет, будут ли перекрываться две диаграммы, если перетащить их близко друг к другу на странице.

Диаграмма - дополнительные параметры

Вкладка Альтернативный текст позволяет задать Заголовок и Описание, которые будут зачитываться для людей с нарушениями зрения или когнитивными нарушениями, чтобы помочь им лучше понять, какую информацию содержит диаграмма.

Вернуться на предыдущую страницу